Altezza help

Discussion in 'Toyota' started by PurgedTT, Feb 7, 2014.

  1. PurgedTT

    PurgedTT New Member

    Joined:
    Jun 21, 2013
    Messages:
    143
    While on my way to work today my car randomly out of no where and no warning started to sputter and hesitate to rev past 2500 RPM and it now sounds like a boxer engine under accleration and has a weird idle....also smells like burning.

    Was running completely fine until just now, revs passed 3000 but its nasty...

    :/ help kinda stumped...coils?
     
  2. _drew

    _drew New Member

    Joined:
    Jun 20, 2013
    Messages:
    236
    Location:
    Richmond BC
    could be a bad coil pack. that would explain the rough idle and inability to rev.

    Is your Altezza a JDM model? I imported some coil packs for a customer with the 3SGE motor.

    The 3SGE motor was used for one or two years on the Altezza platform (Beams RS200) and these certain coil packs are virtually impossible to find! Gotta get lucky on a used set.

    Can you pull the code off your ECU (I'd assume you've thrown a CEL) and find out which cylinder has the misfire? That's a start at least.
     
  3. Derek

    Derek Derek Weldon

    Joined:
    Jun 20, 2013
    Messages:
    444
    Location:
    Yokohama Japan
    Does it run completely fine under 2500 rpm?

    I am not a mechanic and I don't want to confuse the situation but I feel that the coils would show signs of misfire at lower RPM as well.

    I agree with Drew that the check engine light should be checked. However, this car is not OBD2 compliant (even though it uses the same port). Thee are some code readers that will work but it is either trial and error or time to hit the GOOGLEs.

    My somewhat limited opinion is that this could be fuel related by a blockage in the line, strainer, or filter.
    Or it could be related to a busted sensor. These cars use partial electronic throttles which might bum out when under heavy load.

    Good luck and don't forget to come on here and let everyone know what it is once you get it fixed.
     
  4. IMPUL

    IMPUL Collector of fine japanese lawn ornaments

    Joined:
    Jun 24, 2013
    Messages:
    1,577
    Location:
    GTA. Ontario
  5. Dah_Hunter

    Dah_Hunter Looking over your shoulder, so you dont have to.

    Joined:
    Jun 20, 2013
    Messages:
    2,367
    Location:
    Lower Rainland (BC)
    Hmm Maf issue? i know if the MAF is having issues the ECU will go in a limp mode so it start below 3k.
     
  6. PurgedTT

    PurgedTT New Member

    Joined:
    Jun 21, 2013
    Messages:
    143
    No it's a very rough idle at all RPM's and it lets me rev up to any RPM but it feels like it's running on three cylinders maybe.

    The engine is visibly shaking at idle when you pop the hood.

    No check engine or dashboard lights come on at all.

    It's a JDM altezza beams 3S-GE RS200 SXE10 :p.

    When I popped the hood it had a burning plastic smell but there is no fluids anywhere and no smoke out the exhaust of any color.

    Payday isn't until next friday haha fml

    I'll try and get a video up after work.
     
  7. Dah_Hunter

    Dah_Hunter Looking over your shoulder, so you dont have to.

    Joined:
    Jun 20, 2013
    Messages:
    2,367
    Location:
    Lower Rainland (BC)
    could just be a coil pack then.. and its only running on 3 right now that would make sence.. burning plastic smell could be the coil kicking it.
     
  8. PurgedTT

    PurgedTT New Member

    Joined:
    Jun 21, 2013
    Messages:
    143
    90919-02239

    Think I got the right number from toyo diy.

    Going go pull coils tomorrow and see which is the one dead and hopefully it's something simple as that.

    Believe I sourced the right coil pack number $100-200 a pop.
     
  9. Megatol

    Megatol Mr. Toyota

    Joined:
    Jun 22, 2013
    Messages:
    397
    Location:
    Calgary
  10. _drew

    _drew New Member

    Joined:
    Jun 20, 2013
    Messages:
    236
    Location:
    Richmond BC
    my wives Scion XB has been sputtering along, eating coil packs like they are white chocolate covered popcorn lately. This sounds exactly like a dead coil pack to me.

    Let me know if you need help finding the coils.. I found 4 for 3,000? for my customer the other day. They are real hard to find, no doubt! All 4 were used, but they fixed his problem, and he has 3 working ones left!
     
  11. PurgedTT

    PurgedTT New Member

    Joined:
    Jun 21, 2013
    Messages:
    143
    Sounds good drew but in my current financial state I can't afford 4 off my next cheque.

    1-2 is very doable however.

    I'll grab the frame # in the daytime megatol thanks :)

    Pulled coils all affected the except the front one assuming #1 cylinder so it's just a dead coil.

    Now to find one lol.

    Frame #SXE10-0011989
     
  12. Megatol

    Megatol Mr. Toyota

    Joined:
    Jun 22, 2013
    Messages:
    397
    Location:
    Calgary
    Sent PM but will repeat this information here for future reference:

    My catalog shows slightly different number: 90919-02236
    New in Japan costs ~$150 CAD

    On some Russian forum found info that coil pack 90919-02239 is newer version of above and was used on restyle Altezza. So I guess, both should work.

    90919-02239 even cheaper ~105 CAD

    You actually should see part number right on the coil pack.

    Example:
    [​IMG]

    This is parts schema:
    [​IMG]
     
  13. PurgedTT

    PurgedTT New Member

    Joined:
    Jun 21, 2013
    Messages:
    143
    Yeah lordco couldn't help me.

    Went to the local toyota dealership for the hell of it...

    To my surprise they have 4 90919-02239(02236 translated to that in their parts catelog) sitting in a warehouse in vancouver. **However people are saying it doesn't work :(**

    Guess I will be asking _drew to source some used coils I hope.

    Denso IK20 #5403 iridum plugs the same as stock are only $12 a pop at lordco might change those while I'm in there since the maintaince guide says at 100,000 and I'm now at 115,000 KM.

    Any tips on removing the plastic breather on the top of the head it completely covers #3 coil and plug and after years it's rock solid and will crumble if I tug at it I'm sure...but it's solid jeez!

    Timing belt looked great when I pulled the cover off, wish I knew when it was done!

    Thanks mega for the help and information a newb like myself really appreciates it!
     
  14. _drew

    _drew New Member

    Joined:
    Jun 20, 2013
    Messages:
    236
    Location:
    Richmond BC
    the part numbers are very close together, but the parts themselves quite different.

    [​IMG]
    Coil 1: 90919-02227 ST215 Caldina 3SGTE

    Coil 2: 90919-02230 GXE10 Altezza AS200/Lexus IS200 1GFE vvt-i

    Coil 3: 90919-02239 ZZE120 Corolla 1ZZFE

    Coil 4: 90919-02240 NZE121 Corolla 1NZFE

    Coil 5: 90919-02236 SXE10 Altezza RS200 3SGE Beams dual vvt-i

    You'd need #5 .. and they are quite difficult to find new or used! That's the problem with a 15 year old motor that wasn't commonly used haha!

    From looking at the picture.. #3 (02239) looks like its the same "depth" with just a slightly different design. It might work?! If its cheap enough... might be worth a try?
    I sent you a PM in return.
     
  15. PurgedTT

    PurgedTT New Member

    Joined:
    Jun 21, 2013
    Messages:
    143
    Yeah googled it and the guys from tezzaworld said they tried 02239 and no go on the rs200 beams engine for the 1st gens.

    Coil 1 (caldina gtt ST215-3SGE) looks so different but apparently is plug and play and more reliable than the factory ones but I'm not going to risk it and the toyota parts centre said they are discontinued aswell.

    Messaged you back!
     
  16. Megatol

    Megatol Mr. Toyota

    Joined:
    Jun 22, 2013
    Messages:
    397
    Location:
    Calgary
    Found on Japanese website:
    Altezza: 19??/?? - 20??/0? coil pack: 90919-02236
    Altezza: 20??/0? - 20??/0? coil pack: 90919-02239

    and they are different
    proof link: http://tmworks-web.jp/hinban/hdc_toyota.htm
    search for: ???????????????
     
  17. PurgedTT

    PurgedTT New Member

    Joined:
    Jun 21, 2013
    Messages:
    143
    So while I wait for the coil to arrive I don't want my battery to die on me.

    Can I run the car a couple of times to let the alternator charge the battery as I don't have a trickle charger.

    This won't hurt anything or do I hope for the best, feeling cheap money is kinda tight atm with the GF bot working so not having to spend 80-100 on a battery would be good.
     
  18. IMPUL

    IMPUL Collector of fine japanese lawn ornaments

    Joined:
    Jun 24, 2013
    Messages:
    1,577
    Location:
    GTA. Ontario
    Disconnect the negative terminal to stop the trickle loss..I forgot over storage period and my j spec battery is dead. A trickle charger would help if you have one
     
  19. PurgedTT

    PurgedTT New Member

    Joined:
    Jun 21, 2013
    Messages:
    143
    Alright will do that, thanks impul!
     
  20. IMPUL

    IMPUL Collector of fine japanese lawn ornaments

    Joined:
    Jun 24, 2013
    Messages:
    1,577
    Location:
    GTA. Ontario
    Welcome... Also the disconnect could clear the ecu and make it "re-learn"
    Don't worry if for a little bit the idle is off abit at first.. It's searching for optimal AFR..
    And re-teaching itself...